Aller au contenu

Photo

Enlever Un Canal Audio Dans Quicktime


  • Veuillez vous connecter pour répondre
7 réponses à ce sujet

#1 ElvisRobert

ElvisRobert

    Spartan

  • Membre
  • 657 messages
  • Gender:Male
  • Location:Montréal

Posté 31 août 2010 - 06:38

J'ai enregistré une conférence que j'organise (WOWODC, une conférence dédiée à WebObjects) et on a enregistré les présentations avec ScreenFlow. Pour l'audio, on a branché un câble dans le line-in des portables, câble venant de la console audio.

Ça fonctionne bien sauf pour une chose : la piste audio a deux canaux, et le deuxième n'est que du bruit, et le premier canal contient l'audio venant de la console, en sortie à gauche (la piste avec du bruit sort à droite). Dans QuickTime 7, j'ai indiqué au canal avec le bruit d'être désactivé, et que l'autre canal soit en mono. Tout est beau dans QuickTime Player 7, mais dans Safari et la nouvelle version de QT Player, c'est pareil comme avant, l'audio sort qu'à gauche et le canal avec le bruit reste actif.

Est-ce qu'il y a moyen d'éliminer le canal qui n'a que du bruit?
Équipement:

- iMac 17" CoreDuo
- MacBook Pro (début 2008) 15"
- iPhone 3G
- iPod touch
- Dell Inspiron 530 (CentOS Linux)
- Canon Pixma MX700

#2 Flibustier

Flibustier

    Cortland

  • Membre
  • 504 messages

Posté 31 août 2010 - 08:13

Dans Quicktime, ouvre ton clip.

Ensuite, fait "Propriétés de la séquence" (menu "Fenêtre").

Dans cette fenêtre, tu as la piste vidéo et la piste audio.

Clique sur la piste audio, et à droite, tu verra les deux canaux ("Canal" et "Affectation"), "Gauche" et "Droite", qui seront des menus.

Clique sur la piste que tu ne veux plus, et sélectionne "Inutilisé". Pour l'autre, celle que tu veux garder, sélectionne "Mono".

Ensuite, clique sur "Extraire" (en haut, à gauche, fenêtre "Propriétés"). Pouf!, une autre séquence se crée automatiquement, en mono sur gauche et droite.

Revient sur la séquence d'origine, et clique sur "Supprimer" de la fenêtre de propriétés (faut s'assurer que la piste audio est bien sélectionnée). Essaie ta séquence d'origine, elle ne devrait plus avoir de son.

Retourne sur la nouvelle séquence audio mono, et fait une sélection complète (Tout Sélectionner) de cette piste. Ensuite, fait "Copier".

Maintenant, retourne sur ta séquence d'origine, et fait "Ajouter à la sélection et mettre à l'échelle" (menu "Édition"), ça va se coller tout seul sur la séquence.

Voilà!
eMac 1.42 Ghz, Combo Drive, 2 gigs mémoire, 80 Gigs DD
MacBook 1.83 Ghz, 2 Gigs Mémoire, DD 250 Gigs

#3 ElvisRobert

ElvisRobert

    Spartan

  • Membre
  • 657 messages
  • Gender:Male
  • Location:Montréal

Posté 31 août 2010 - 08:34

Je viens d'essayer, et la nouvelle séquence (faite par l'extraction) a quand même deux canaux :-/
Équipement:

- iMac 17" CoreDuo
- MacBook Pro (début 2008) 15"
- iPhone 3G
- iPod touch
- Dell Inspiron 530 (CentOS Linux)
- Canon Pixma MX700

#4 Flibustier

Flibustier

    Cortland

  • Membre
  • 504 messages

Posté 31 août 2010 - 08:55

T'as définitivement sauté une étape, parce que, ici, ça fait exactement ce que j'ai écrit dans l'autre intervention! Si t'as encore la piste avec un son inaudible, c'est que tu n'as pas sélectionné "Inutilisé" pour cette piste. La nouvelle séquence audio qui se crée prend automatiquement les setups que tu lui as donné, et si tu as sélectionné "Inutilisé", tu ne devrais pas l'entendre dans la nouvelle séquence audio.

Peut être aussi que t'as un peu d'interférences dans la piste que tu veux garder?
eMac 1.42 Ghz, Combo Drive, 2 gigs mémoire, 80 Gigs DD
MacBook 1.83 Ghz, 2 Gigs Mémoire, DD 250 Gigs

#5 ElvisRobert

ElvisRobert

    Spartan

  • Membre
  • 657 messages
  • Gender:Male
  • Location:Montréal

Posté 02 septembre 2010 - 04:19

Voilà les deux fenêtres dans QuickTime Player 7 :

http://macti.ca/QT7.mov

Comme on peut voir, en créant la nouvelle séquence, c'est encore deux canaux.
Équipement:

- iMac 17" CoreDuo
- MacBook Pro (début 2008) 15"
- iPhone 3G
- iPod touch
- Dell Inspiron 530 (CentOS Linux)
- Canon Pixma MX700

#6 Flibustier

Flibustier

    Cortland

  • Membre
  • 504 messages

Posté 02 septembre 2010 - 09:29

Moi aussi, dans les propriétés, ça me donne une piste son qui avec le canal 1 en mono, et le 2 inutilisé. Sauf que ce qui joue maintenant, c'est la piste 1 du côté gauche et droite, donc, complètement mono.

Pour que ça devienne effectif, fait une exportation! T'auras par la suite les canaux 1 et 2 totalement identique.
Ou juste exporter la piste son que tu viens de créer, et la ré-ouvrir dans Quicktime, avec des canaux identique G et D, piste audio que tu pourras ajouter à ta séquence.
eMac 1.42 Ghz, Combo Drive, 2 gigs mémoire, 80 Gigs DD
MacBook 1.83 Ghz, 2 Gigs Mémoire, DD 250 Gigs

#7 ElvisRobert

ElvisRobert

    Spartan

  • Membre
  • 657 messages
  • Gender:Male
  • Location:Montréal

Posté 02 septembre 2010 - 01:43

Est-ce que tu as la piste active des deux côtés dans QuickTime Player X (la nouvelle version dans 10.6)? Le truc fonctionne très bien sous QT 7, mon problème reste avec QT X (et Safari).

Je vais essayer un export de la piste audio, mais si tu peux me dire que ça fonctionne bien avec QuickTime X sur ton poste, j'apprécierais.
Équipement:

- iMac 17" CoreDuo
- MacBook Pro (début 2008) 15"
- iPhone 3G
- iPod touch
- Dell Inspiron 530 (CentOS Linux)
- Canon Pixma MX700

#8 Flibustier

Flibustier

    Cortland

  • Membre
  • 504 messages

Posté 02 septembre 2010 - 02:10

Non, je ne peux te confirmer pour X, je n'ai pas Snow. Pour 7.6.6, ça fonctionne. Quand on ouvre la piste audio seulement, après extraction et la mise en mono, puis exportation, celle-ci indique bien "Gauche" et "Droite" lorsque ouverte après exportation. Même chose si j'exporte les piste vidéo et audio dans une même séquence, lorsque ouverte avec Quicktime 7.6.6, la piste audio indique aussi "Gauche" et "Droite". Et j'ai ce que je veux sur les deux canaux audio, soit la piste mono avant exportation, qui joue maintenant sur les 2 canaux, bien indiqués "Gauche" et "Droit".

Désolé pour Quicktime X, je suis encore sur Leopard.

Rien ne t'empêche de faire un petit test avec une petite partie de ta séquence, comme une petit 2 minutes, pour faire des tests.
eMac 1.42 Ghz, Combo Drive, 2 gigs mémoire, 80 Gigs DD
MacBook 1.83 Ghz, 2 Gigs Mémoire, DD 250 Gigs




1 utilisateur(s) li(sen)t ce sujet

0 membre(s), 1 invité(s), 0 utilisateur(s) anonyme(s)